[office365] Message Attachment Size Limit Error

Incident Report for Front

Resolved

There has been a significant reduction in the number of failures for Office 365 requests with attachments larger than 3 MB. We will continue to monitor.
Posted Apr 22, 2025 - 21:56 UTC

Update

Office 365 servers may sometimes fail to accept attachments larger than 3 MB. As a temporary alternative, we suggest using another method of sharing files with recipients, such as OneDrive. We have communicated the issue to Microsoft and are investigating additional mitigations.
Posted Apr 17, 2025 - 18:47 UTC

Investigating

We received reports from a small number of customers that some drafts error when sending, with the message:
"Unexpected problem sending attachment larger than 3MB to Office 365."
Posted Apr 17, 2025 - 13:15 UTC
This incident affected: O365.