[office365] Some customers experiencing delays receiving messages on Office365 channels

Incident Report for Front

Resolved

Issue is not resolved, opening a partner incident instead: https://front-partners.statuspage.io/incidents/sdln9wvbqdb7

Please contact Microsoft for assistance with an affected mailbox.
Posted Apr 25, 2025 - 15:19 UTC

Update

We are continuing to investigate this issue.
Posted Apr 25, 2025 - 11:42 UTC

Investigating

We are currently investigating delays for inbound messages on some Office365 channels.
Posted Apr 25, 2025 - 10:28 UTC
This incident affected: O365.